开发笔记 首页 > 开发笔记

php阿里云短信 invalidtimestamp.format.expired

图文分享 ubb 发布时间:2019-07-15 20:54:07 已被阅读: 10 织梦帝国微信小程序

生成此错误问题的原因是阿里去的时区和我们所使用的时区是不匹配的。阿里云短信使用的是gmt时区的时间,而我们的服务器通常用的是北京时间,这样的话,就会有时间差。解决方案就是如下面代码

[]=gmdate().;
[]=str_replace(,,[]);

//即使用gmt时区的函数,但生成的时间为

2019-12-12GMT12:12:12Z

但这个格式和阿里云短信需要的时间格式还是有差别。于是再用str_replace函数替换GM即可。

要注意上面的.Z要后面加上去,不要写在格式字符串里面!

友情链接:
在线客服
微信号

微信扫码加好友